破洛洛手机网
当前位置: 首页 > 服务器 > WEB服务器 > 正文

PHP重要安全升级说明 推荐升级php 5.2.17版本

作者:佚名 来源:网络整理 2013-1-3

以下文档发布于2011-3-22日

为了进一步提高PHP程序的安全问题,星外要求所有用户升级到PHP5.2.17以上版本,升级办法如下:
(对于装了Zend的用户,您需要删除ZEND,删除zend时全部选默认就可以,升级PHP成功后您可以再一路默认装上ZEND.)

1.停止IIS,在控制面板,添加删除中删除PHP安装包
2.删除C:\windows\php.ini

3.下载最新版本PHP安装包.下载地址 http://www.jb51.net/softs/26087.html

4.安装最新版本PHP安装包.重启IIS


对于特殊原因无法升级PHP的用户,我们要求您对C:\windows\php.ini作以下修改:

找到:
disable_functions =
这行,改为
disable_functions =exec,system,passthru,popen,pclose,shell_exec,proc_open,curl_exec,multi_exec,dl,chmod,

注意所有内容应该在一行中,不要换行

找到:
disable_classes =

改为

disable_classes =DOTNET,

保存后重启IIS后马上生效。

文中所有软件 s.jb51.net均有下载。

推荐阅读